Announcement

Collapse
No announcement yet.

Add Custom Profile Fields in Postbit

Collapse
X
Collapse
First Prev Next Last
  • Filter
  • Time
  • Show
Clear All
new posts

    #61
    Thanks Glenn - just bought you a couple "PayPal" beers!

    Comment


      #62
      Thanks!

      coffee GIF

      Comment


        #63
        Hey glennrocksvb thanks for yet another great mod!
        I seem to be having an issue with the message icon not showing. I have an RTL forum so tried to change in the css to the rtl version of the .png file (Also exists on server) but that didn't work either.

        You can check it live here for example: https://hakafe.net/node/35

        Thanks

        Comment


          #64
          Quick follow up if that is of any help, while inspecting the page with Chrome there seems to be an error

          Click image for larger version

Name:	error.JPG
Views:	0
Size:	53.1 KB
ID:	14540

          The icon file address points to: /js/ckeditor/skins/moono/icons.png , I checked and this file doesn't exist in that folder.

          Thanks again.
          Attached Files

          Comment


          • glennrocksvb
            glennrocksvb commented
            Editing a comment
            That is a known issue on 5.4.4 and I believe is fixed in 5.4.5.

          #65
          And one final issue to report, this seems to mess up the alignment on the mobile style, even if I leave just one field. When removing all fields (with the mod still on), this problem goes away on mobile. Anyway to disable this on mobile styles?

          Comment


          • glennrocksvb
            glennrocksvb commented
            Editing a comment
            By default, the profile fields are styled with display:inline-block which means they are displayed next to each other in the same line until it wraps to the next line. If you want each field to display in its own line, then you need to set it to display:block

            Code:
            .l-small .b-userinfo__additional-info {
                display: block;
            }

          #66
          Originally posted by watershed View Post
          I seem to be having an issue with the message icon not showing. I have an RTL forum so tried to change in the css to the rtl version of the .png file (Also exists on server) but that didn't work either.
          It looks like starting vB 5.4.4 or 5.4.3, they changed the old PNG sprites file and removed the envelope icon. The preferred and new way of using icons is via the SVG sprites. This is the SVG sprites used on your forum: https://hakafe.net/sprite.php?stylei...&ts=1542587853. So try using this code instead (changes are in red):
          Code:
          .send-pm-in-postbit:before {
              content: '';
              width: 15px;
              height: 14px;
              position: relative;
              bottom: -1px;
          background: transparent url(https://hakafe.net/sprite.php?styleid=36&td=rtl&sprite=sprite_icons_general.svg&ts=1542587853) no-repeat 0 -176px;
              display: inline-block;
          margin-{vb:stylevar right}: 3px;
          }

          Comment


            #67
            how to add the country flag png to it?

            Comment


              #68
              I've tried this mod as well, but doesn't show the location in postbit. Maybe there's a bug.

              Comment


              • glennrocksvb
                glennrocksvb commented
                Editing a comment
                Did you configure the mod in AdminCP > Settings > Options > Custom Profile Fields in Postbit Settings > Profile Fields to Add to Postbit to specify the profile field IDs to show on postbit?

              #69
              Originally posted by glennrocksvb View Post
              Did you configure the mod in AdminCP > Settings > Options > Custom Profile Fields in Postbit Settings > Profile Fields to Add to Postbit to specify the profile field IDs to show on postbit?
              Yea, I got field 2 and 4 there.

              Comment


                #70
                Did you specify it as field2,field4 instead of just 2,4?

                Comment


                  #71
                  Originally posted by glennrocksvb View Post
                  Did you specify it as field2,field4 instead of just 2,4?
                  Yeah, its field2,field4

                  Comment


                    #72
                    Make sure those fields in the User Profile Field Manager in AdminCP have the "Private Field" option set to No. And also if those fields are empty in the User Setttings for a user, then those fields are not displayed in postbit.

                    Comment


                      #73
                      Originally posted by glennrocksvb View Post
                      Make sure those fields in the User Profile Field Manager in AdminCP have the "Private Field" option set to No. And also if those fields are empty in the User Setttings for a user, then those fields are not displayed in postbit.
                      How about if they are empty only for some users, not all? Still won't appear?

                      Comment


                      • glennrocksvb
                        glennrocksvb commented
                        Editing a comment
                        It will appear for users who filled out the fields.

                      #74
                      Yes, I've checked now and is set to NO.

                      Maybe there's something wrong with module?

                      Comment


                        #75
                        ‚ÄčThe mod works here. I'd have to check your setup to see what's wrong.

                        Comment

                        Working...
                        X