Announcement

Collapse
No announcement yet.

CKEditor Drag and Drop Image Upload

Collapse
This is a sticky topic.
X
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #61
    Originally posted by glennrocksvb View Post
    Is there any error message in the browser console or in the server logs?
    Here's what I am seeing Glenn:

    Click image for larger version

Name:	Error.jpg
Views:	190
Size:	124.6 KB
ID:	7506

    Comment


    • glennrocksvb
      glennrocksvb commented
      Editing a comment
      What's in the Network tab?

    • glennrocksvb
      glennrocksvb commented
      Editing a comment
      PM me the uploader.php file that you modified and I'll take a look.

    • glennrocksvb
      glennrocksvb commented
      Editing a comment
      Got the uploader.php file and checked it but the required changes are not there.

    #62
    i am using 5.3.4 beta and it is worling just fine
    Wise men say nothing Fools never listen

    Comment


    • glennrocksvb
      glennrocksvb commented
      Editing a comment
      Thanks for confirming it works in 5.3.4 Beta

    #63
    Originally posted by glennrocksvb View Post
    Got the uploader.php file and checked it but the required changes are not there.
    Thanks Glenn, I made the mistake of uploading unedited files rather than the modified one. lol

    Comment


      #64
      So my users have difficulty uploading images from their Android devices and iPhone devices. Does this mod allow them to drag and drop from other websites into the ckEditor, or even just gallery images?

      Comment


      • alfreema
        alfreema commented
        Editing a comment
        Right, with Android it's not too bad. I was able to open two browser tabs in separate split screen, but drag and drop and copying an image didn't work (as you already know).

        I think one of the issues with iPhone is that there is some internal caching going on and they keep grabbing the cache URL and pasting that. I haven't tested on my wife's iPhone yet to see what they are doing though. I was just hoping there would be some easier way for them to take an image and post it.

      • glennrocksvb
        glennrocksvb commented
        Editing a comment
        Did you mean iPhones cache the clipboard content? Even if you copy a new url, the clipboard still contains the old url? That sounds odd.

      • alfreema
        alfreema commented
        Editing a comment
        No, on the iPhone when they copy the URL to the clipboard, it frequently has a URL that is a local filesystem reference to a cached version of whatever image they are wanting to post, instead of the original URL that goes off to the image being hosted on a website. So instead of http:// it's something like cache:// (don't quote me on the syntax, but you get the idea).

      • glennrocksvb
        glennrocksvb commented
        Editing a comment
        On Android, when you long press an image, there is an option to open image in a new tab where you can copy the image url from. Doesn't iOS have the same option?

      • alfreema
        alfreema commented
        Editing a comment
        Not sure, but I will try that on my wife's phone.

      #65
      The ErrorMessage-Language is not the correct one.
      How could I set the language to german? The translation-file is there. But it is not working.
      HTML Code:
      CKEDITOR.plugins.setLang( 'filetools', 'de', {
          loadError: 'Während dem Lesen der Datei ist ein Fehler aufgetreten.',
          networkError: 'Während dem Hochladen der Datei ist ein Netzwerkfehler aufgetreten.',
          httpError404: 'Während dem Hochladen der Datei ist ein HTTP-Fehler aufgetreten (404: Datei nicht gefunden).',
          httpError403: 'Während dem Hochladen der Datei ist ein HTTP-Fehler aufgetreten (403: Verboten).',
          httpError: 'Während dem Hochladen der Datei ist ein HTTP-Fehler aufgetreten (Fehlerstatus: %1).',
          noUrlError: 'Hochlade-URL ist nicht definiert.',
          responseError: 'Falsche Antwort des Servers.'
      } );
      vBulletin-Forum.de Das deutschsprachige vBulletin 5 Forum! | Widgets, Free & Exclusive Mods and Tutorials.
      You will find a lot of good stuff here!

      Comment


      • glennrocksvb
        glennrocksvb commented
        Editing a comment
        I'll look into it.

      #66
      Still works in vb5.4 beta 1
      Wise men say nothing Fools never listen

      Comment


      • glennrocksvb
        glennrocksvb commented
        Editing a comment
        Thanks for letting us know!

      #67
      Originally posted by glennrocksvb View Post
      Unfortunately, this mod requires editing existing ckeditor JS files as vB didn't make it developer-friendly to easily add ckeditor plugins without hacking the JS. This means, you have to edit the JS files every time you upgrade. I'm thinking of making something that would easily update the files without manually editing them by hand.
      Any plans or progress on this? That is, making something that easily updates the files?

      I just upgraded to 5.4.0 and had an issue on my first attempt. Got it the second time around. Just looking to make things easier should you create something.

      Comment


      • glennrocksvb
        glennrocksvb commented
        Editing a comment
        Thanks for letting me know. Now that you've asked, an idea popped into my head on how to implement this in an easier way.

      #68
      Is it possible when a photo is to large to drag and drop instead of getting a server error message when the photo is to large to get a error that says, " FIle to large?"

      Comment


      • glennrocksvb
        glennrocksvb commented
        Editing a comment
        I'll check.

      #69
      Can confirm it works on vb5.4.1 rc1
      Wise men say nothing Fools never listen

      Comment


        #70
        I am getting reports this does not work with MAC browsers. After the poster drags a image to the message box a small box appears with a question mark centered in it.

        Comment


          #71
          Originally posted by ejbreeze View Post
          I am getting reports this does not work with MAC browsers. After the poster drags a image to the message box a small box appears with a question mark centered in it.

          What browser, Safari or Chrome?

          Can you or anyone else here with Mac reproduce the issue? I don't have Mac to test.
          Helpful? Donate. Thanks!
          Fast VPS Host for vBulletin: A2 Hosting & IONOS

          Comment


            #72
            Originally posted by glennrocksvb View Post
            Can you or anyone else here with Mac reproduce the issue? I don't have Mac to test.
            No issues here on the latest versions of Safari, Chrome, Firefox and Opera.

            Comment


            • glennrocksvb
              glennrocksvb commented
              Editing a comment
              Thanks for checking!

            #73
            Drag and Drop uploaded with mac and firefox


            Click image for larger version

Name:	IRONMAN70.3_WiesbadenEC_10years_Anniversary_Logo_neg-580x282.jpeg
Views:	82
Size:	32.7 KB
ID:	10535
            vBulletin-Forum.de Das deutschsprachige vBulletin 5 Forum! | Widgets, Free & Exclusive Mods and Tutorials.
            You will find a lot of good stuff here!

            Comment


              #74
              Does not work in 5.4.2 alpha 4 using imagemagick (incorrect server response) but works using GD
              Wise men say nothing Fools never listen

              Comment


                #75
                Originally posted by willie53 View Post
                Does not work in 5.4.2 alpha 4 using imagemagick (incorrect server response) but works using GD
                Thanks for reporting. Can you please check the server error logs for detailed error messages?
                Helpful? Donate. Thanks!
                Fast VPS Host for vBulletin: A2 Hosting & IONOS

                Comment

                Working...
                X