Announcement

Collapse
No announcement yet.

vB5 AutoLinker

Collapse
This is a sticky topic.
X
X
Collapse
First Prev Next Last
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    I have only added around half a dozen links to amazon and in after a month or so have made a few sales.

    My greatest problem is trying to make the links look as non intrusive and non distracting while reading the content. I wanted them distinct from regular hyperlinks so I have settled on just underlining the Amazon hyperlinks without a color change:

    Click image for larger version

Name:	Amazon Links.jpg
Views:	1
Size:	122.2 KB
ID:	8754

    Christian Forums

    Comment


    #32
    This is pretty slick. So far i have over 117 links.

    Thanks for this mod, glennrocksvb
    If by chance some day you're not feeling well and you should remember some silly thing I've said or done and it brings back a smile to your face or a chuckle to your heart, then my purpose as your clown has been fulfilled ~ Red Skelton

    Comment


      #33
      Currently 941 links and no drop in performance.

      Comment


        #34
        You need to be logged in to view the quote. Login or Register now!
        I temporarily added é in the word héllo in my AutoLinker settings on this site. If that becomes a link then it works as long as I keep that word.

        Comment


        • glennrocksvb
          glennrocksvb commented
          Editing a comment
          Can you try using UTF-8 as charset? If that doesn't work, try adding the character again, load a topic with that character, then check the error logs on the server.

        • Fleiding
          Fleiding commented
          Editing a comment
          I switched to UTF-8 and it's working. However, I reverted to ISO-8859-1 as all special characters broke. When I switched back the links are still working, so all is well.

        • glennrocksvb
          glennrocksvb commented
          Editing a comment
          Glad it's working now. It was odd it didn't work initially with the same charset.

        #35
        I am running into a problem with this. I originally had all my autolinks point to files in a separate directory inside the forum root folder and it worked fine.

        I have since moved all those documents to the "Help" module and changed all the links to the corresponding location. I see that it links correctly to the Help module, and displays the correct url in the browsers search box, but the page doesn't display the correct url, it appears to show the first document in the Help module, or the landing page.

        I suspect it may be a refresh issue with vBulletin, and not the mode since it points to the correct url.

        Thoughts? What else to look into?

        If by chance some day you're not feeling well and you should remember some silly thing I've said or done and it brings back a smile to your face or a chuckle to your heart, then my purpose as your clown has been fulfilled ~ Red Skelton

        Comment


        • glennrocksvb
          glennrocksvb commented
          Editing a comment
          It works here

          https://vbmods.rocks/help#community_...l_lostpassword

          Check the browser debug console for any Javascript error.

        • NumNum
          NumNum commented
          Editing a comment
          No errors, but i did find the issue. The sort feature, some were set at 0 which would make them land on the home page and not go to the actual page?

          seems to be working fine now.

        • glennrocksvb
          glennrocksvb commented
          Editing a comment
          Glad you figured it out.

        #36
        I am looking forward for version 2.0.

        Comment


          #37
          You need to be logged in to view the quote. Login or Register now!
          It's not coming anytime soon until vB implements some hooks it requires.

          Comment


            #38
            glennrocksvb I think I've found a bug.

            I have the following set in my Admin CP:
            • Word 1
            • Word 2
            • Word 3
            When I write these words as "Word 1 & Word 2" the second word doesn't convert to a link, but if a write these words as "Word 1 and Word 2" it does work. If I place Word 2 above Word 1 in the Admin CP, Word 1 doesn't convert to a link. When I remove the "&" everything works as it should. This happens on all languages and charsets. ItIt happens

            Comment


            • glennrocksvb
              glennrocksvb commented
              Editing a comment
              I'll look into it. Thanks for reporting.

            #39
            It looks like this ampersand (&) issue occurred recently in the latest or last few versions. I have a 5.3.0 on my local and I can see this Autolinker mod works with & symbol in a word. I will investigate more what vBulletin had changed that affected this mod.

            Comment


              #40

              Hi,

              I've downloaded vBulletin 5.4.1 and installed Autolinker module and it works fine. But in case of 5.2.2 it doesn't work. How can I fix this problem?

              Is it a compatability issue? Is there any possibility to fix it by changing any template or any core program?

              Thanks.

              Comment


              • glennrocksvb
                glennrocksvb commented
                Editing a comment
                I will check. But why don't you upgrade? 5.2.2 is no longer supported anyway. They will not release security patches on unsupported versions.

              #41
              Glenn, could you please check on something for me ... Here my AutoLinker Settings:
              Click image for larger version  Name:	Capture5.PNG Views:	1 Size:	420.7 KB ID:	10483

              it works for me for most links but for example here look at the last 2 posts in this thread:
              https://kasinoforum.com/forum/online...lege-mehr-habe
              Vera & John or Vera&John or Laplingo should all get linked according to my setting but they are not.



              Update: I copied Lapalingo to the top of my conversion list and now the link shows. However, there is nothing else in my conversion list that should interfere as far as I can tell

              Comment


              • glennrocksvb
                glennrocksvb commented
                Editing a comment
                This is the same issue that Fleiding reported in post #38. I haven't found a fix for it yet. For now use "and" instead of "&".
            Working...
            X