Announcement

Collapse
No announcement yet.

Delay after hitting post

Collapse
X
Collapse
First Prev Next Last
  • Filter
  • Time
  • Show
Clear All
new posts

  • Delay after hitting post

    I'm getting around a 9 second + delay after hitting post when creating a thread. Any idea where to begin or how to trace down this issue?

    This is what I am seeing under network in Firefox. It just lags for 9+ seconds while waiting for the forum to display the new post. As you can see in the screen shot it was taken 10+ seconds after hitting the post button:



    Thanks,
    William
    Christian Forums

  • #2
    There's a lot of things going on when submitting a post aside from saving the post itself. Among other things, the system has to get the subscribers to the topic/channel and then send them notifications. If the topic has a lot of subscribers, this may take a while to process. It's really difficult to pinpoint exactly where the bottleneck is.

    Comment


    • #3
      This delay has only recently occurred. It appears whether creating a new thread or posting a reply. It appears to have happened sometime after the addition of memcached and 5.3.2. Not blaming either, just giving the timing of the occurrence.

      I take it I can just comment out the memcached in the config file to isolate that from being the issue?

      And lastly, I think I better pull cloudflare offline just to make sure that too isn't the issue.

      If the problem isn't resolved by those two things I'll be at a loss other than disabling all products and hooks .... which I guess I should try too.

      Thanks,
      William
      Christian Forums

      Comment


      • #4
        Yeah you can do those steps to isolate the issue.

        Comment


        • #5
          Glad I checked the config file. Memcached was commented out. Now I receive an error when memcached is enabled in the config file: A System Error has occured.

          The software is experiencing a systems error.

          You should attempt to repeat your last action. If this error occurs again, please contact the site administrator.

          Christian Forums

          Comment


          • #6
            Enable debug mode to see the exact error.

            Comment


            • #7
              Done. Just a blank page and it says: Error :Memcached is not installed on line 69 in /home/xxx/public_html/core/vb/memcache.php
              Christian Forums

              Comment


              • #8
                Regardless, that's not my current problem. I'll worry about that when the time comes. I verified that I did request memcached installed though some time ago. I'll keep poking around for solutions to my delay when creating a post or responding.

                Thanks,
                William
                Christian Forums

                Comment


                • #9
                  Could it be that your server is doing some security checks on all POST requests and this causes the delay?

                  Comment


                  • William
                    William commented
                    Editing a comment
                    How would I know?

                  • glennrocksvb
                    glennrocksvb commented
                    Editing a comment
                    Ask your host. They may have added some precautionary measures to all POST requests as a result of the recent DDoS attacks on their servers.

                  • William
                    William commented
                    Editing a comment
                    Thanks Glenn. I made a ticket and asked the question.

                • #10
                  You need to be logged in to view the quote. Login or Register now!
                  Asked them. Two days later they said the server is performing below normal after extensive checks.

                  They can duplicate my issue by logging into my account and making a post. They asked me to contact the software vendor.

                  So, I decided today to switch to PHP 7.0+ from 7.1.8 but the site just shows a service error. I contacted them again and told them I cannot run anything below 7.1.8 on the site when it is compatible. Still waiting.

                  I have disabled the PHP FPM which seemingly disables Opcache, just trying to isolate further. From what I learned FPM enables other php.ini files from which I assume Opcache is being enabled from, because without FPM the Opcache is not caching files.

                  Support is very slow at A2 Hosting. So, I'm waiting for a response as to why I can't use PHP 7.0 or even PHP 5.6.

                  William
                  Christian Forums

                  Comment


                  • #11
                    Did you check the error logs when you got an error using 7.0?

                    Comment


                    • #12
                      You need to be logged in to view the quote. Login or Register now!
                      Just tried again after blanking out my error_log in root directory. I also checked Cpanel's error log for the last 300 errors and nothing new surfaced.

                      I just switched it back to 7.1.8 again.
                      Christian Forums

                      Comment


                      • #13
                        Host still hasn't responded back. I narrowed down the issue of the site not displaying with php 5.6 and 7.0. If memcached is enabled in the config file then the site will not work. Downgrading to 7.0 did not fix the issue though.

                        Glenn, is this something you can tackle?

                        I just want the response time back. I do not care about getting memcached working with 5.6 to 7.0. But I have to get rid of this delay while using 7.1.
                        Christian Forums

                        Comment


                        • William
                          William commented
                          Editing a comment
                          Now they tell me. From support: I took a look through EA (whm -> easyapache4 ), it looks like memcache(d) is not supported by cPanel in anything under php 7.1 .

                          This would be why you're seeing an issue with memcache in anything lower.

                          Unfortunately, we're not really able to step terribly far outside of the cPanel recommended settings here, as this could cause some serious server problems.

                      • #14
                        Issue has been resolved: https://www.vbulletin.com/forum/foru...332-long-delay

                        Site is working up to speed. Thanks though for your support Glenn!

                        Enjoy,
                        William
                        Christian Forums

                        Comment


                        • #15
                          Glad Joe was able to figure it out that emptying searchlog table would fix the issue.

                          Comment

                          Working...
                          X