Announcement

Collapse
No announcement yet.

Stop Links in Posts

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Still cannot reproduce the issue using the same options you are using.

    Steps 3.1 to 3.6 are not required for vB 5.5.4.
    Helpful? Donate. Thanks!
    Fast VPS Host for vBulletin: A2 Hosting & IONOS

    Comment


    • elektro-kot
      elektro-kot
      Junior Member
      elektro-kot commented
      Editing a comment
      Ok, so I understood the instructions correctly.

      Could this happen due to language settings? I use Russian.

    • glennrocksvb
      glennrocksvb
      Founder/Coder
      glennrocksvb commented
      Editing a comment
      I can't say without looking into it and testing it.

    #17
    Originally posted by glennrocksvb View Post
    I can't say without looking into it and testing it.
    OK. Could you take a look at the language pack, please?

    Comment


    • glennrocksvb
      glennrocksvb
      Founder/Coder
      glennrocksvb commented
      Editing a comment
      I can't tell by just looking at the language pack. I'd have to look at the plugin code on the server and debug it to see at which point of the code the functionality breaks.

    • elektro-kot
      elektro-kot
      Junior Member
      elektro-kot commented
      Editing a comment
      Hi Glenn.
      Understand thanks.
      There seems to be a problem with PHP
      I checked: on my server with PHP 7.3.9 there is a problem, on the test server with PHP 7.1 mod works fine

    • glennrocksvb
      glennrocksvb
      Founder/Coder
      glennrocksvb commented
      Editing a comment
      Can you check the server logs for any PHP errors? Also try enabling debug mode to see if any PHP error appears on the page.

    • elektro-kot
      elektro-kot
      Junior Member
      elektro-kot commented
      Editing a comment
      Yes, I will try and let you know the results later. Thank you

    #18
    Originally posted by glennrocksvb View Post
    Still cannot reproduce the issue
    Sorry, Glenn, I described the issue incorrectly.
    Language packs and PHP are not relevant to this issue.

    Now I understand and, I think, the problem is not with the mod, this is a problem with the advanced editor of vBulletin.

    If I manually specify BBcode, the module disable the link, but if I writed the link, then selected it and in the advanced editor clicked the BBcode icons - bold text, url ... etc, then the link is skipped.

    Please let me know if you see this problem.

    Stops link

    Click image for larger version  Name:	stoplink_1s.jpg Views:	0 Size:	55.2 KB ID:	20206

    Skips link

    Click image for larger version  Name:	stoplink_2s.jpg Views:	0 Size:	73.0 KB ID:	20207
    Click image for larger version  Name:	stoplink_3s.jpg Views:	0 Size:	71.5 KB ID:	20208
    Click image for larger version  Name:	stoplink_4s.jpg Views:	0 Size:	53.0 KB ID:	20209

    Comment


    #19
    Did this mod ever get sorted to work correctly?

    Thanks,
    Kether

    Comment


      #20
      Originally posted by kether View Post
      Did this mod ever get sorted to work correctly?

      Thanks,
      Kether
      Hi everyone. I'm really interested in this mod, but do not want to buy something that isn't working. Any updates? Does this work with VB 5.6.0?

      cheers,
      Kether

      Comment


        #21
        I hate "me too" replies on my forum but I agree with Kether, stopping links would be great but only if it works well. (I'm using VB 5.6.0 too)
        Last update by @glennrocksvb this thread was 10 months ago.

        Comment


          #22
          kether
          Junior Member
          kether ,
          ayjayef
          Junior Member
          ayjayef

          Hi.
          The first version of the module worked fine, there was one error (previously i reported a problem).

          Recently, Glenn has released an update (version 1.1), everything works perfect now.

          Comment


            #23
            I just posted a test from low post count account above with a link in it and it has correctly hid the post in a moderation queue.

            ...but, it emailed the subscription notification with the hidden spam link in it to everyone who is subscribed to this thread.

            Bug?

            Comment


              #24
              Originally posted by ayjayef View Post
              I just posted a test from low post count account above with a link in it and it has correctly hid the post in a moderation queue.

              ...but, it emailed the subscription notification with the hidden spam link in it to everyone who is subscribed to this thread.

              Bug?
              That's a good catch. That looks like a bug. But even without this mod vB should not have emailed subscription notifications in the first place if a post is in moderated queue, right? That seems like a vB bug in itself. Other users should not see the moderated posts in the email.
              Helpful? Donate. Thanks!
              Fast VPS Host for vBulletin: A2 Hosting & IONOS

              Comment


                #25
                I'm not smart enough to know if it's vB or your addon but I'm sure you'll make sense of it.

                I've not seen it happen on my site though.

                Comment


                #26
                I bought the mod, simple install into vBull 5.6.6 and the mod works well on all our testing including the spammers sneaky color changed links, thanks!

                I can confirm that if someone is subscribed to the thread or the sub-forum they will get email notification of a new post showing the moderated content which is not ideal. Hopefully we can workout how to stop that.

                Comment


                • ayjayef
                  ayjayef
                  Junior Member
                  ayjayef commented
                  Editing a comment
                  Good question, on my site the subscriber was an admin but on your site (this thread) I'm not an admin and it did the same.

                • glennrocksvb
                  glennrocksvb
                  Founder/Coder
                  glennrocksvb commented
                  Editing a comment
                  Can you test with a regular user subscriber on your site?

                • ayjayef
                  ayjayef
                  Junior Member
                  ayjayef commented
                  Editing a comment
                  Just created a new user and can confirm they received email notification with the the message and it appears in their message centre too... both with the link in a post that is waiting for moderation.

                • glennrocksvb
                  glennrocksvb
                  Founder/Coder
                  glennrocksvb commented
                  Editing a comment
                  Now can you temporarily disable this mod and then try again? Just want to confirm it works without the mod.

                • ayjayef
                  ayjayef
                  Junior Member
                  ayjayef commented
                  Editing a comment
                  Not really, if I disable the mod then the post won't be auto-moderated and the 2nd user would get an email anyway.

                #27
                This bug became real today. Stop Links in Posts blocked a spammer (great!) put the message in a moderation queue and emailed all those subscribed to the area. One of our users followed the forum link in his email notification and got and error that he wasn't allowed to view (as expected as it's in the moderation queue). Contacted us to ask why he was blocked!

                Comment


                  #28
                  Ok I think I know what's going on now. The PHP hook that is used to set the reported post into moderation queue that the mod is doing is vB's onAfterContentAddOrUpdate hook function which means the spam post has been saved already before vB triggered this hook. So at that point, vB has triggered the email notifications to the subscribers (as it normally does for a new post) before the mod is able to automatically disapprove the post.

                  To resolve this issue, vB should add a PHP hook right before it triggers the email to the subscribers to let third-party mods be able to cancel the email.

                  I will see if I can manually add a PHP hook as a temporary solution. If this is feasible, this would require editing existing PHP code which means this would have to be re-applied after every vB upgrade.
                  Helpful? Donate. Thanks!
                  Fast VPS Host for vBulletin: A2 Hosting & IONOS

                  Comment


                  • ayjayef
                    ayjayef
                    Junior Member
                    ayjayef commented
                    Editing a comment
                    My experience of vB development is that they'll never do something to help a third party mod which wouldn't be news to you either.

                    Re applying a code fudge after future upgrades is a pain to remember but at worst, it ends up like it is at the moment until I see the problem and patch again so that's not too bad a result.

                  #29
                  I think I found a solution that doesn't require a new PHP hook or editing existing PHP code. I just need to test it thoroughly.
                  Helpful? Donate. Thanks!
                  Fast VPS Host for vBulletin: A2 Hosting & IONOS

                  Comment


                  #30
                  ayjayef
                  Junior Member
                  ayjayef, I have deployed the fix here on this site. Can you test using your other account?
                  Helpful? Donate. Thanks!
                  Fast VPS Host for vBulletin: A2 Hosting & IONOS

                  Comment


                  • ayjayef
                    ayjayef
                    Junior Member
                    ayjayef commented
                    Editing a comment
                    That works on this site. Spamtester posted a link in reply to this post and it's in the moderation queue. ayjayef didn't get email notification of a new post.
                    I think you've fixed the quirk.

                Latest Topics

                Collapse

                Working...
                X