Announcement

Collapse
No announcement yet.

Show all the recipients in a PM

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Show all the recipients in a PM

    Hi all,

    Currently when using the regular private messaging option (not the vB messenger) when sending a message to multiple users, the text is shown as such :

    "[Username], I and 1 other are in this conversation"
    As shown by the screen capture below :

    Click image for larger version

Name:	OUhTGf4.jpg
Views:	45
Size:	20.8 KB
ID:	16389

    I find that a bit silly, especially with a link that leads to nowhere on the "1 other".
    Is there a way around that ?
    I'm not familiar enough to know in which file the correction could be done, but I don't wait to be spoonfed a solution (even though I would appreciate )

    It can be for security purposes as the vB messenger is showing all the users in the conversation, might me a bug.

    Thanks in advance for any help

    #2
    It's a bug. I attempted to find if there's an easy temporary fix but unfortunately, the fix requires big code changes in the template and in the PHP code. You need to report it to the vB support forum. I'm sure there's already a bug ticket for it but I don't know the URL. If you post in the support forum, the staff might be able to find the bug report or open a new one.
    Helpful? Donate. Thanks!
    Fast VPS Host for vBulletin: A2 Hosting & IONOS

    Comment


      #3
      That's what I thought, thank you very much for your insight, I'll see if there's a bug ticket already and will post it there too

      Cheers

      Comment


        #4
        Small update on that, since I don't have access to the support forum (I'm not the one with the licenced account for my forum) I can't see anything regarding tickets and bugs.

        You mentioned big changes in both template (which I'm currently looking at) and in PHP code, do you happen to know what type of changes and where does they need to go (not asking for the fix, just a file for me to look out)

        Comment


        • Glaudiar
          Glaudiar commented
          Editing a comment
          I think it's in core/vb/library/content/privatemessage.php but could be wrong

          Do you happen to know if this bug has been fixed in recent release by any chance ? I could look at the way they did it before an upgrade is scheduled

        • glennrocksvb
          glennrocksvb commented
          Editing a comment
          It's been a couple of months ago I don't remember where the changes need to be. I don't know if they've fixed this.

        • Glaudiar
          Glaudiar commented
          Editing a comment
          But as far as 5.4.5 goes (I'm on 5.4.2) it's not fixed right ?
          I shall try to get access to the tracker area to see if that was fixed

        #5
        Curious one this

        How did I get a message on this subject from this category ? I have never made a post to it so can't be a subscriber, can I ?

        Comment


        • Glaudiar
          Glaudiar commented
          Editing a comment
          Happened to me once here in the past on a subject I wasn't a subscriber, nor poster. Vb works in mysterious ways sometimes !

        #6
        Check the button at the upper right of this topic page. Does it say "Subscribed"?
        Or on the "vBulletin Issues & Questions" channel where this topic belongs, does it say "Subscribed"?
        Helpful? Donate. Thanks!
        Fast VPS Host for vBulletin: A2 Hosting & IONOS

        Comment


        • O i O -U too
          O i O -U too commented
          Editing a comment
          it does indeed do so. Don't get me wrong Glenn~ I AM SUBSCRIBED to you and this forum Period!

          Just curious as to how i got a PM on this, since.. well as said

        #7
        This has been fixed in 5.5.1 according to the tracker : https://tracker.vbulletin.com/vbulle...sues/VBV-19163

        Comment

        Working...
        X