Announcement

Collapse
No announcement yet.

My forums4.25 not work, please help me

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    My forums4.25 not work, please help me

    Hi
    I had installed and configured two vbulletin 4.2.5 forums both of which worked perfectly on a webhosting

    Now they both give this error, what happened? they both give the same error



    Deprecated: The behavior of unparenthesized expressions containing both '.' and '+'/'-' will change in PHP 8: '+'/'-' will take a higher precedence in /home/xxxxxx/public_html/includes/class_core.php on line 5842

    PHP Warning: Use of undefined constant MYSQL_NUM - assumed 'MYSQL_NUM' (this will throw an Error in a future version of PHP) in ..../includes/init.php on line 165

    PHP Warning: Use of undefined constant MYSQL_ASSOC - assumed 'MYSQL_ASSOC' (this will throw an Error in a future version of PHP) in ..../includes/init.php on line 165

    PHP Warning: Use of undefined constant MYSQL_BOTH - assumed 'MYSQL_BOTH' (this will throw an Error in a future version of PHP) in ..../includes/init.php on line 165

    PHP Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in ..../includes/functions_navigation.php on line 588

    PHP Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in ..../includes/functions_navigation.php on line 612

    PHP Warning: Creating default object from empty value in ..../includes/functions_navigation.php on line 547

    PHP Warning: Use of undefined constant userid - assumed 'userid' (this will throw an Error in a future version of PHP) in ..../includes/class_bootstrap.php(433) : eval()'d code on line 45

    PHP Warning: mysqli_query(): (42000/1064): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 in ..../includes/class_core.php on line 1386

    #2
    I know that this reply came a little bit too late, but this error is due to an incompatible PHP version configured on your server.

    For that version of vBulletin, you need to install and configure PHP 5.6

    Comment

    Working...
    X